Symptom
- In the check tool, when exporting the results, only 100 record are exported even though >100 results are present.
- As an SF administrator, I attempted to retrieve the results from the check tool that I have just run and I noticed that only 100 records are showing up although I expected to see 100+
Environment
SAP SuccessFactors HCM suite
Reproducing the Issue
- Navigate to the Check tool
- Click on 'Migration' tab
- Export results of any check which has >100 results (say 200 results)
- The exported file has only 100 records
Cause
- This is a expected behavior in 2H 2022.
- A guardrail is placed to only persist 100 issues, when a check is implemented to run asynchronously, but when the check is triggered on UI again, the export feature downloads all results (up to 10,000).
Resolution
- As this works by design, you can follow the below steps to download >100 check results.
- Run the check again (i.e Synchronous run).
- Export the results -> All records will be exported up to 10,000 (NOTE: If the page is refreshed, you would need to follow the steps again)
- Engineering team has worked on enhancing a message to be notified on the UI, on this behviour.
Keywords
KI2211, 2211, 2H 2022, migration, rules, check tool, 100, export, TLS-26385, INC3049008 , KBA , LOD-SF-PLT-CHK , SuccessFactors Platform Check Tool , LOD-SF-EC-CHK , SuccessFactors Employee Central Check Tool , Problem
Product
SAP SuccessFactors Employee Central all versions