SAP Knowledge Base Article - Public

3265512 - Agent Desktop (Customer Hub): Only a maximum of four labels/fields in the Header, even when more are defined in the customer hub settings

Symptom

  • You are using the Agent Desktop add-on in C4C
  • You are trying to configure additional fields for the Individual Customer Header, but only a max of four (4) fields are visible in the header
  • Two of the fields (Customer ID and Name) cannot be moved or removed

Environment

  • SAP Cloud for Service
  • SAP Cloud for Sales
  • Agent Desktop Add-on

Reproducing the Issue

  1. Go to Administrator
  2. Select Service and Social
  3. Navigate to "Configure Agent Desktop"
  4. Select "Customer Hub Settings" and then select "Individual Customer"
  5. Add more fields
    AD_add_more_Fields.png
  6. Go to the Agent Desktop (Services -> Agent Desktop) and search for an Individual Customer, then confirm
  7. Look at the Header, and notice only a max of four (4) labels are displayed even when you have added more in step 5

Cause

  • Due to UI constraints, only a max of labels is allowed to keep the user experience, look and feel consistent
  • Prevent UI inconsistencies

Resolution

  • Per design, even when there are options to move the main header labels, the system will preserve the location in the UI (same restriction applies to the Account/Header)
  • Customer ID and Name are standard and cannot be removed or moved
  • Due to the design constraints, only two additional labels would be visible in the Header, and the system will consider from top down (two fields after "Name")
  • SAP recommends using the General Information and adding the labels found from the list
  • At the moment, no additional labels can be added to the list

Keywords

Agent Desktop, Fields, Labels, Header, Customer HUB, settings, Customer ID, Name, Owner, ABC Classification , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , LOD-CRM-LA , Live Activity , Problem

Product

SAP Cloud for Customer core applications 2211