Symptom
The Output items of channel Email seems to be fine (status Completed) however, Output does not reach respective recipients.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to Business Application Document and check Output Requests.
- Output items of Email channel are correctly determined and have 'Completed' status.
- Although everything seems to be fine, email does not reach recipient.
Cause
Current Sender Domain does not have a sender policy framework (SPF) record Published hence it might be classified as spam and do not reach the recipients.
Resolution
Please Note:
Any tool like MX Tool Box may be used.
The first two steps check whether the DNS TXT record settings are already in place. Only if this is not the case, step three must be followed.
- Go to https://mxtoolbox.com/SuperTool.aspx.
- Provide the domain as myXXXXXX.mail.s4hana.ondemand.com or myXXXXXX.mail.saps4hanacloud.cn.
- Create a specific SPF record (or TXT record) in the sender DNS by specifying IPs from the previous step.
Example:
v=spf1 include:_spf.cmail.ondemand.com ~all
Please, check complete instructions on Chapter 4.2.6 Publish SPF Record for Sender Domain of Output Management Set Up Instructions.
See Also
- 2941522 - Output Management in SAP S/4HANA Cloud Public Edition - Guided Answer
- Output Management Set Up Instructions
Keywords
Email, Reach, Inbox, All, Correct, Output, Parameter, Determination, Email, Transmission, Sent, Recipients, Empty, not, working, Completed, Domain, Sender , KBA , CA-GTF-OC , SAP S/4HANA output management , Problem