Symptom
You're trying to filter out user Information (User entity) based on their Status using Integration Center but couldn't find the field in User entity.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- Employee Central
- OData API
Reproducing the Issue
1. Create an Integration from Integration center
2. Select User entity as starting entity
3. Goto "Filter and Sort" and in "advanced filters", you don't see "Status" field.
4. You try to add "Status" filed to configure fields, but it's not present in User entity.
Cause
There are two reasons for this issue.
1. If the Status field is not present in User entity, then it's not enabled in Employee Profile.
2. If it's enabled but not present in "Advanced Filters" then it's not filterable.
Resolution
To enable the "Status" field, please navigate to
SF -> Manage Business Configuration -> Employee Profile -> Standard -> status.
Change "Enabled" from No to Yes.
Check below image for reference:
See Also
2569829 - Is it possible to make some field filterable in OData API? (sap.com)
2324204 - How to retrieve inactive employees via Integration Center? - SAP ONE Support Launchpad
Keywords
Fiter Status, User entity, Status filed missing, Inactive Status Users for Integration Center, Status is Contained in inactive, active, t, f, inactive, active, terminated, Integration center, enabled, disabled. , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , LOD-SF-INT-API , API & Adhoc API Framework , Problem