Symptom
You are searching for a record using basic search in OWL and you can find it; using same information in the column search, however, you cannot find the record.
Environment
SAP Cloud for Customer
Reproducing the Issue
We will use Accounts work center view as example but this applies to any OWL.
- Go to the Customers work center.
- Open the Accounts work center view.
- In the OWL, insert ABC in the basic search box (where ABC is a search criteria).
- You notice results DEF being displayed as result (where DEF are records displayed from search made with ABC criteria).
- Now in column GHI, type ABC (where GHI is a column in OWL).
- You see different results than DEF.
You expected to see same results in step 6 and 4 since criteria is the same and screen is the same.
Cause
The basic search in OWL performs a fuzzy search (search for text that matches a term closely instead of exactly). The column filter/search performs an exact search (no fuzzy search logic).
Resolution
This is the system current standard behavior and is valid for any OWL.
Keywords
Search ; Column ; OWL ; Engine ; Fuzzy ; Incorrect ; Wrong ; Result ; Results ; Not Correct ; Different; Exact ; Filter ; , KBA , LOD-CRM-ACC , Account , AP-RC-UIF , C4C UI Framework , How To