Symptom
- You are using the Agent Desktop add-on
- You perform a search in the Knowledge Base tab but get the following error (Connection Failed)
- To fix the above connection error, you will need to configure the Knowledge Base Widget, but you are not able to save the changes
Image/Data is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Cloud for Customer
- SAP Cloud for Sales
- MindTouch
Reproducing the Issue
- Go to Administrator -> Service and Social
- Navigate to "Configure Knowledge Base Widget"
- Select MINDTOUCH under Knowledgebase Providers
- Enter the required information
Cause
- Missing configuration
- All fields should be filled
Resolution
- Ensure that all fields are properly filled
- This includes the Path prefix to show trending articles (this is a new mandatory field)
- Site URL - API URL
- Path prefix to show trending articles:
- This Path prefix for Trending articles is from the MindTouch API
- We recommend using "/@api/deki/pages/popular"
- User - user name for account
- Key
- Secret
- Contact the 3rd party provider to ensure all the fields have the expected entries
Keywords
MindTouch, KBA, Knowledge Base Integration, Agent Desktop , KBA , configure knowledge base widget , mindtouch , LOD-CRM-SBS-AC , Agent Console Add-on , Problem
Product
SAP Cloud for Customer core applications 2208