SAP Knowledge Base Article - Public

3266645 - Error caused by different delimiters in app Manage Workforce

Symptom

There are two types of Delimiters available in the Manage Workforce app: 1. Comma (,), 2. Semicolon (;).

If customers don't upload the template for the corresponding delimiter in the app, there will be following error messages:

  1. PersonExternalID XXXXX can only contain upper case letters, numbers, '_', '.' and '-'.
  2. Worker: XXXXX - Profile Information is mandatory.
  3. Worker: XXXXX - Business Partner Role is mandatory.

Environment

SAP S/4HANA Cloud, Public Edition

Reproducing the Issue

  1. Open the Manage Workforce app
  2. Click the "Import" button
  3. Select either "Worker and Work Agreement" or "Worker" option
  4. Select the Comma (,) delimiter
  5. Click "Download Templates"
  6. Fill the template using semicolon as delimiter
  7. Upload the CSV file to the Manage Workforce app
  8. Errors will occur

Cause

Different delimiters in CSV file will cause system identification errors.

Resolution

Check the selection and template, and upload again.

See Also

Keywords

Import Employee, Download Templates, CSV, Manage Workforce, semicolon, comma, worker, work agreement, application log, can only contain upper case letters  , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , CA-GTF-BUM , Business User Management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions