Symptom
There are two types of Delimiters available in the Manage Workforce app: 1. Comma (,), 2. Semicolon (;).
If customers don't upload the template for the corresponding delimiter in the app, there will be following error messages:
- PersonExternalID XXXXX can only contain upper case letters, numbers, '_', '.' and '-'.
- Worker: XXXXX - Profile Information is mandatory.
- Worker: XXXXX - Business Partner Role is mandatory.
Environment
SAP S/4HANA Cloud, Public Edition
Reproducing the Issue
- Open the Manage Workforce app
- Click the "Import" button
- Select either "Worker and Work Agreement" or "Worker" option
- Select the Comma (,) delimiter
- Click "Download Templates"
- Fill the template using semicolon as delimiter
- Upload the CSV file to the Manage Workforce app
- Errors will occur
Cause
Different delimiters in CSV file will cause system identification errors.
Resolution
Check the selection and template, and upload again.
See Also
Keywords
Import Employee, Download Templates, CSV, Manage Workforce, semicolon, comma, worker, work agreement, application log, can only contain upper case letters , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , CA-GTF-BUM , Business User Management , Problem