SAP Knowledge Base Article - Public

3267482 - Registered Product QC Not Showing SDK Fields

Symptom

 You have created PDI fields and added them to the Registered Product Quick Create screen, but they are not visible.

Environment

SAP Cloud for Customer

Cause

 Extension fields belonging to /IBASE/INSTALL_POINT cannot be added to old Registered Product QC (/BYD_COD/ServiceOnDemand/RegisteredProduct/UI/COD_Registered_Product_QC.QC.uicomponent) which is based on controller object (RegisteredProductOIFEnhancedController). This is an old limitation.

Resolution

To allow this to be possible a new Quick Create Screen was developed. (/BYD_COD/ServiceOnDemand/RegisteredProduct/UI/COD_Reg_Prod_N_QC.QC.uicomponent) which is based out of InstallationPoint BO.

The new QC can be enabled via scoping question;

  • Service -> Entitlement Management -> Registered Products and Installed Base
  • Business Option: Additional options for Registered Product, Installed Base and Installation Points 
  • Question: "You can enable the new Registered Product Quick Create that allows you to add extension fields from Installation Point business context" 

Keywords

BC; Customization; Fields; Extension; Extensibility , KBA , LOD-LE-IBA-IPO , Installation Point , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions