SAP Knowledge Base Article - Public

3267483 - A Deleted Org. Management Unit Cannot Be Recovered

Symptom

As part of system cleanup activities, you have accidentally deleted some of Org. Management Unit and its hierarchy.

Environment

SAP Cloud for Customer

Reproducing the Issue

An Org. Unit can be deleted in many ways.

In this example, the Org. Unit was deleted this Data Worbench in the following way:

  1. Log into C4C;
  2. Go to Data Workbench WC;
  3. Access the Export view;
  4. Select the object for which you wish to delete records;
  5. Filter for the desire records and export them;
  6. Download the CSV file from the Monitor;
  7. Edit the CSV and add a column with header "ToBeDeleted" at the end;
  8. For all records that should be deleted, add value "TRUE" in this column;
  9. Save the file and re-upload it to the system using the Update option in the Import view.
  10. Set the mark for deletion to "True";

Cause

A deleted org unit cannot be recovered.

It's only remaining as a root anchor for linkages, but inner details like, for example, child linkages are/were removed.

Resolution

Currently, if a hierarchy should be kept, but not be used anymore, delimiting the org units would have been the way to go.

This is the current system expected behavior.

An alternative option may be to check the SAP Cloud for Customer, Customer Influence to submit an idea:

Keywords

system behavior; deleted; deleted org.; org unit; recovered; cannot be recovered. , KBA , LOD-LE-OM-OM , Org. Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2211