Symptom
IPS job is failing with error:
Source path: $.personKeyNav.userAccountNav.username is not available in content, but is required in defined system transformation
Users cannot be synced to IAS from SuccessFactors as a result
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Run IPS sync job
- Notice job runs with errors
- Following error is shown: Source path: $.personKeyNav.userAccountNav.username is not available in content, but is required in defined system transformation
Cause
Username value is missing for user in SuccessFactors internal User Account Database table
Resolution
- This data issue was caused by a legacy defect in system many years ago, the root cause was resolved in a past release, however that only stops this from happening going forward with new users.
- For the users already with the problem - they needed to be corrected directly in the Database.
To confirm that you are affected, follow the below steps:
- Go to Employee Export;
- Confirm that User and their Username exists in System and UDF
- Go to Data Inspector
- Query Table Table_USER_ACCOUNT
- Query on Username field with your user username;
- No data in User Account DB Table for this Contingent Worker
- Please raise a case with component LOD-SF-PLT-IAS and support will assist in the Database fix
- If you have data on the User Account, confirm that you have user active and your IPSADMIN user with all permissions according to KBA 2791410, if so raise a case to LOD-SF-PLT-IAS
See Also
Keywords
userAccountNav.username, IPS sync, fail, user, UserAccountNav, username , KBA , LOD-SF-PLT-IAS , Identity Authentication Services (IAS) With BizX , BC-IAM-IPS , Identity Provisioning Service (IPS) , Problem
Product
SAP SuccessFactors HXM Core all versions