SAP Knowledge Base Article - Public

3268026 - Can we make Customer API call when Business Partner feature is enabled on Quote 2.0 tenant?

Symptom

  • Your CPQ tenant is on Quote 2.0 engine and by default the Business Partners (BP) feature is enabled.
  • You are trying to make the "Customer" REST API call but when trying to do that from CPI you're receiving an error that "API is unavailable because Business Partners feature is Enabled".
  • PFA screenshot.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SALES CLOUD CPQ

Cause

  • When Business Partners (BP) feature is enabled, then 'Customers/Customer Roles' won't be available anymore.
  • It's either of the two.
  • Please do notice that the 'Customers/Customer Roles' option won't be available under the CPQ Setup menu if the BP feature is enabled on a Quote 2.0 tenant.

Resolution

  • This is happening as per design.
  • It's not a limitation.
  • You would need to use the Business Partner API call when BP feature is enabled on your tenant.

See Also

https://webcomcpq.com/webapihelp/index#/BusinessPartner

Keywords

Business Partners, Quote 2.0, Customers/Customer Roles, Customer API, Quote 2.0 , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions