Symptom
Customer part number is not working as expected in a sales order scenario.
When selecting a distribution chain in the product master data under the sales tab, it is possible to set up a customer part number X which is valid for a specific account XYZ (where X is customer part number and XYZ is the account ID). In the sales document it is then possible to add a product using the customer part number instead of the product ID to determine the product.
Therefore the expectation is as follows: When creating a sales document with a different account LMN (where LMN is the account ID) and entering the product ID ABC (where ABC is the product ID), the product should not be determined, since it is only a valid customer part number for account XYZ.
But this does not work accordingly.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Sales Order work center
- Under Common Tasks view, select New Sales Order sub-view
- Select account ID XYZ
- Click on View All
- Go to Items tab and add product ID ABC
The product ID ABC is determined for account ID XYZ, which is as expected since a customer part number is maintained under the Product Master Data .
- Go to Sales Order work center
- Under Common Tasks view, select New Sales Order sub-view
- Select account ID LMN
- Click on View All
- Go to Items tab and add product ID ABC
The system will also allow to add product ID ABC, which is not expected, since the product ID ABC should be linked to account ID XYZ only.
Cause
The customer part number validation only works in B2B sales order scenarios. For a normal sales order, the behaviour does not apply.
Resolution
This is the expected system behaviour.
Keywords
Customer Part Number, Sales Order, Product, B2B, Different, Incorrect, False. , KBA , AP-SLO-SO , Sales Order , Problem