Symptom
- A candidate was moved from Recruiting to Onboarding (Ready to Hire) but does not show up in the Onboarding Dashboard.
- The candidate was previously seen in the Onboarding Dashboard but the Onboarding process was cancelled. The candidate was re-initiated again but after re-initiating, the candidate still did not appear in the Onboarding Dashboard.
- The candidate is now an employee and needs to be hired to be paid.
Environment
- SAP SuccessFactors Onboarding
Cause
- Missing mandatory value
Resolution
Please note:
- This process is strictly for External Users and Non-Rehire Users coming from Recruitment.
- If the candidate lands into Business Process Tile after New Hire Data Review/Personal Data Collection (whichever is first), then this workaround shouldn’t be executed.
Solution:
- Go to BPE: Monitor Processes
- Filter by Onboarding Process ID
- Check whether the top most task awaiting to complete is "exception.Onboarding2CreateExtUserErrorWorkflow".
- If so, click on status column of bottom most task that belongs to definition "Onboarding2Workflow".
- Scroll down and go to Variables section.
- Navigate to second page under Variables section and copy value of variable processInstanceIdMP
- Invoke below API to cancel BPE Process and clear all pending To-Do Items
API to Invoke: /odata/v2/restricted/cancelBPEProcess
Payload:
{
"processInstanceId": "SUPPLY_COPIED_VALUE_IN_STEP_6"
} - Go to Data Inspector, use Entity Table_USERS_SYSINFO and apply filter by Username and click on Show Data. Scroll if necessary and copy value of Users Sys ID (this step can be skipped if we already know User ID to Inactive and Purge).
- Using copied Users Sys ID, follow KBA https://launchpad.support.sap.com/#/notes/3141240 to Inactivate User.
- [Optional] Based on requirement, perform Inactive User Purge to clear all user and personal data.
Keywords
Cancel Process Support when candidate is under Business Process Tile, Recruiting, Onboarding 2.0, Onboarding, OBX, RCM, Business Process , KBA , LOD-SF-OBX-CAN , Cancel Onboarding , Problem
Product
SAP SuccessFactors HXM Suite Core 2205