SAP Knowledge Base Article - Public

3270095 - "4240 - Duplicate identity for this provider" error message appears when trying to enable Custom SAML SSO authentication in SAP Analytics Cloud (SAC)

Symptom

The following error occurs in SAP Analytics Cloud (SAC) when enabling Custom SAML SSO configuration:

    • message: "dberror(PreparedStatement.execute): 4240 - Duplicate identity for this provider: line 1 col 36 (at pos 35)"
      stack: ""

  • There are no duplicate emails in SAC for the System Owner's user.
  • Opening the SAC tenant URL, it is being redirected to the default IdP logon page.
  • During the configuration, the user verification is successful, user attributes are matching between SAC and IdP.
  • After failing with enabling the Custom SAML SSO configuration, the tenant will have duplicate IdPs assigned to it (instead of switching the default to the custom one). This is documented in this KBA.

Environment

  • SAP Analytics Cloud (Enterprise) 2022.21.5

Reproducing the Issue

  1. Open SAC System->Administration->Security menu with System Owner user.
  2. Enable Custom SAML SSO configuration based on help page article up until step 17.
  3. When clicking on "Save" button, notice the error.

Cause

  • This issue is currently under investigation by development.

Resolution

  • This issue is currently under investigation by development.

See Also

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Keywords

sac, custom idp, custom saml sso, sso configuration, idp setup, sso not working, custom idp can't, duplicate idp, duplicate identity provider, 4240 , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0