Symptom
User A is not able to change user B‘s job classification to a specific value XXXXXX.
Admin user is able to do so.
Scenario: Change a user's job classification
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
1. Proxy user A > insert a jobinfo record from action or "pencil" for user B.
2. Try to change job classification to XXXXXX > "No data" is displayed.
3. Proxy Admin user > insert a jobinfo record from action or "pencil" for user B.
4. Try to change job classification to XXXXXX > XXXXXX is displayed and can be selected.
Cause
This is an expected behavior. User A doesn't have any permission to View or Edit Higher Grades.
The "View Higher Grades" option defines whether a manager/admin can view an employee's job classification if it is higher than the manager's/admin's.
Resolution
Give user A the View or Edit Higher Grades permission
Employee Data > HR Action > View Higher Grades
See Also
Keywords
View Higher Grades, job classification, permission, jobinfo, job history, HR Action , KBA , LOD-SF-EC-RBP , Roles & Permissions (EC Core only) , Problem