Symptom
When you execute a IRPA bot in the IRPA factory, Jobs are failing with below error
Your job cannot be distributed because no agent can handle this SDK version
Environment
SAP Business Bydesign
Reproducing the Issue
- Login into IRPA Factory
- Execute a bot
- Go to Monitoring tab
Here you find the error message for the respective bot
Cause
SDK version in the project is not up to date
Resolution
1) For Projects Created in Cloud Studio
To resolve the issue, go to your project in the factory and update the SDK versions in the project. You will then be able to create a new package with the updated SDK versions and should no longer see an error for the SDK versions.
This can be done as per the Help Center documentation Update a Dependency
In case there is no project, the cause could that when you acquired the bot from the store, the bots were available in packages tab, not under project tab. You need to create the project from the package in order to update the SDK.
2) For Projects Created in Desktop Studio
SDK-s are coming together with Desktop Studio. Therefore you need to install the latest Desktop Studio, open your project, generate a new package and import this package to Cloud Factory.
Keywords
irpa, job, sdk version, agent, factory , KBA , irpa, job, sdk version, agent, factory , AP-ML-RPA-PRV , ByDesign - Robotics process Automation - Tenant Provisioning , Problem