Symptom
You have set up your system to use the Confirmation Update Run and created a RUN XYZ (XYZ represents the Run ID). When you execute the Run, it updates the Availability of your Demand (Sales Order) with the Date dd.mm.yyyy (dd.mm.yyyy represents a calendar date). However, when you same ATP check manually for the same Demand (Sales Order), the system returns a different date xx.mm.yyyy (xx.mm.yyyy represents a calendar date).
Hence, you would like to understand why the system is behaving this way.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Outbound Logistics Control work center.
- Go to the Automated Actions and select Confirmation Update Runs.
- Find and select the Run ID: XYZ.
- Execute the Run and wait for it to finish.
- Find and open the Application Log once the Run has finished running.
- Go to the Customer Demand view.
- Find the relevant Sales Order.
- Select any Line Item and go to the Schedule Lines sub-tab:
- Note down the dates on the row Confirmed for: Execution start date, shipment date, delivery date.
- Now select all Order Line Items of the Customer Demand.
- Click Actions and select Check Availability.
- Go to the Schedule Lines sub-tab again and compare the Dates.
- You can see the Confirmed Dates differ from the previous Dates that have been updated by the Confirmation Update Run.
Cause
The dates on the confirmed schedule line after the manual Availability Check and the Confirmation Update Run may differ due to the sorting criteria defined in the Run. For instance, you have maintained in the relevant Run various sorting criteria such as Requested Delivery Date, Delivery Priority, Document Creation Date and Items for Complete Delivery First. All of these are taken into consideration when the confirmation Update Run is executed.
Resolution
System is therefore working as designed.
Keywords
Confirmation Update Run, Check Availability, Manual, ATP, Customer Demand, Actions , KBA , AP-CR-CR , Customer Requirement , Problem