Symptom
The error message "User XXXXXXXXXXXX" does not exist in the system is displayed when changing payment approvers for bank account from App Maintain Payment Approver.
Environment
SAP S/4HANA Cloud.
Reproducing the Issue
- Delete the Payment Approver XXXXXXXXXXXX from the App Maintain Business Users.
- Business user YYYYYYYYYYYY is maintained as payment approver in the workflow.
- Customer is trying to a add new Approver in this app Maintain Payment Approver / Revoke authorization for the old Payment Approver XXXXXXXXXXXX.
- Encountering an error because of another user 'XXXXXXXXXXXX' in workflow. This user has been deleted from the system.
Cause
The CB user ID of the user XXXXXXXXXXXX has been delete by the system administrator. The CB user id XXXXXXXXXXXX is still maintain as Payment Approver in a Bank Account.
Resolution
Pleas, do the following configuration settings :
- Use app “Configure Your Solution” to Open SSCUI “Change Message Control for Bank Account Management”
- Add new entry as below
- Msg No. "187" Message Text "Payment approver & does not exist" ; Online = "W" Batch = "W" Standard = "E".
Now, in the App Maintain Payment Approver you will be able to revoke the authorization for deleted payment approver and add a new payment approver.
- Revoke authorization for user XXXXXXXXXXXX and,
- Add new Payment Approver.
In both of these steps please, select the checkboxes.
- Select check box Bypass Validation.
See Also
Help documentation for the App Maintain Payment Approver
Keywords
"187", "Payment approver & does not exist", S4_PC, F1372 , KBA , FIN-FSCM-CLM-BAM , Bank Account Management , FIN-FSCM-CLM-BAM-2CL , Bank Account Management (Public Cloud) , How To