Symptom
When trying to activate a workflow in the "Manage Sales Document Workflows" app the following message is raised: "Select rework as the required action for the rework exception".
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to "Manage Sales Document Workflows" app.
- Select 'Workflow for Debit Memo Requests' option from the drop down.
- Select the relevant workflow.
- Click on "Activate".
- The following error message is raised:
"The operation has been cancelled
Cause: Select rework as the required action for the rework exception."
Cause
Incorrect configuration.
Resolution
- The rework should be handled as an exception in the 'Release' step of the workflow.
- Set "Rework" as the required action for the "Rework" exception by following the below steps:
- Navigate to the exception handling within the workflow which has been configured.
- Set "Rework" as the required action for the "Rework" exception.
See Also
- Approval Workflows for Sales Documents: https://help.sap.com/docs/SAP_S4HANA_CLOUD/a376cd9ea00d476b96f18dea1247e6a5/5a5f3f686c06490893a588c99b36adca.html?locale=en-US
- Manage Sales Document Workflows: https://help.sap.com/docs/SAP_S4HANA_CLOUD/a376cd9ea00d476b96f18dea1247e6a5/82db0a77a4ee48cda01f873d5a416bd2.html?locale=en-US
Keywords
Sales, SD, S/4HANA Cloud, credit, debit , workflow, work flow, activate, rework, DMR, rework required, rework,Select rework as the required action for the rework exception , KBA , SD-SLS , Sales , SD-SLS-2CL , Sales (Public Cloud) , Problem
Product
SAP S/4HANA Cloud 2208