Symptom
A territory realignment run cannot be activated with the error "Action ACTIVATE not possible;action is disabled"
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work centre
- Go to the Realignment Runs view
- Click New
- Enter data as needed
- Proceed to create
- Error "Action ACTIVATE not possible;action is disabled" stops you from activation/ creation of the run.
Cause
In the step 2 of the creation of the Realignment Run (RR) you can click in the 'maintain territory rules' hyperlink. This makes the system open a window with a table where you can define all rules for the realignment. This window needs to be saved and closed to finally create the RR (in step 4).
The RR will look into the table and start - if the table is under edition (open) the RR would not be sure of how to proceed, thus the error message "Please close the Rules UI". Since it cannot proceed (activate), it shows a second message "Action ACTIVATE not possible; action is disabled" (to make sure that the Rules are properly set before triggering a RR).
Resolution
Just close the other windows before the last step and retry.
Keywords
KBA , LOD-CRM-TM , Territory Management , Problem