SAP Knowledge Base Article - Public

3275284 - Service Start Date does not Show Expected Value for Rehiring

Symptom

You have rehired an employee, and notice that the field Service Start Date does not show the expected date according to the set date in the rehire process.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Personnel Administration.
  2. Navigate to the Regular Tasks view.
  3. Click on Rehire Employee.
  4. Perform the rehire of a previously terminated employee.
  5. After the process is finished, you can see the unexpected date in the field Service Start Date in the employee screen.

Cause

The Service Start Date field will behave differently when the "Reinstatement" option is turned on.

Resolution

If service start date is not filled during the rehire and ‘Reinstatement’ is unchecked, the service start date will be the same as the rehire date of the employee.

However if ‘Reinstatement’ is checked, the previous length of services is also to be considered for calculating the service start date.

As an example, if an employee was initially hired on 01.01 and terminated on 10.01, it has a total of 10 service days.

In case you rehire this employee on 01.05, there are 2 possibilities for the Service Start Date:

  • If the Reinstatement option is checked, the service start date will be backed 10 days, so it would display 20.04.
  • If Reinstatement is not checked, the date will show normally as 01.05

Keywords

Reinstatement, re-hire, termination , KBA , SRD-HR-PAD , Personnel Administration , How To

Product

SAP Business ByDesign all versions