Symptom
You are migrating Leads from an External system to SAP Business ByDesign. After migrating the Leads, the Lead ID's in the system are different from those maintained in the Migrated file.
Environment
SAP Business ByDesign
Reproducing the Issue
To migrate Leads:
- Go to the Business Configuration work center.
- Select the Overview view.
- Search and Open the activity Migration of Leads.
- Select Migrate leads using the migration tool.
- Upload the Migration File from Data from Migrate template.
- Execute Migration from Execute Migration Step by Step.
- Migration is Completed.
To check the availability of the migrated Lead ID:
- Go to the Marketing work center.
- Go to the Leads view.
- Search for the Migrated Lead ABC (where ABC represents the Lead ID you maintained in the migration file).
- Unable to find the Lead ID: ABC
Cause
When you migrate Leads into the system, the system will use the New Lead ID's of the migration service, from the Internal Number Ranges.
However, you must fill the Lead ID field in the migration template which is the identifier for the Lead. It is used for the template-internal identification between different worksheets and will not be migrated. The system will use the internal numbering during the creation of Leads for the Lead ID.
Resolution
It is not possible to upload the same Lead IDs as maintained in the Number Range in your External system. This is the expected system behavior.
Keywords
Leads, Lead ID, Migration of Leads , KBA , SRD-CRM-MKT , Marketing , Problem