Symptom
Customer created a payment batch that was sent to the bank via MBC and got an error saying that No Short Keys created during bank statement upload.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Upload bank statement.
- Create a Payment batch.
- Sent to the bank.
- File was rejected.
Cause
Bank Account with leading zero.
Mismatch between the bank file and the bank account master data with respect to the account number.
Resolution
The mismatch in leading zeros between the bank file and the bank account master data see app Manage Bank Accounts. It can be solved in three ways:
Solution A:
Remove/add leading zero of account number used in the file according to the requirement.
Solution B:
Create a new bank account with/without the leading zero to match the account number used in the file.
The steps to follow:
- Open the old account in ‘Manage Bank Accounts’ and edit it.
- Click tab ‘House Bank Account Connectivity’.
- Select the house bank account and click ‘Delete’.
- Click ‘Save’ to save the changes.
- Then create the bank account with/without leading zero again.
Solution C:
Maintain the Alternative Bank Account Number for House Bank Account Connectivity for bank account in app Manage Bank Accounts.
For example, the bank account number is 12345678, but the bank file brings 0012345678. The alternative bank account number can be maintained as 0012345678.
Keywords
MBC, leading zero, Short key, Manage Bank Accounts, Bank file , KBA , FI-BL-PT-BA , bank statement , FI-BL-PT-BA-2CL , bank statement (Public Cloud) , Problem