Symptom
Why do I see the value “no user set” in approvers field of Cases table even though a Process owner has been set in the diagrams attributes?
Environment
SAP Signavio Process Governance 3.0
Reproducing the Issue
- Open Process manager Dictionary
- Create a new Owner entry that includes a users email.
- Open Process Manager Explorer
- Create a new BPMN 2.0 process.
- In the diagram level attribute 'Process owner', link the new Dictionary entry.
- Save the changes.
- Navigate back to the Explorer page.
- Trigger the approval workflow for this process.
- Open Process Governance
- Select the Cases tab
- Filter the Cases table for the above process.
- See under the approvers column for the newly created case, their is the value 'no user set'.
Cause
You are seeing the value 'no user set' in the approvers field as the email that was entered into the Dictionary entry for the process owner does not match this users email address in SPM or PG.
Resolution
To resolve this issue, please change the users email address in the Dictionary item to match the users email in SPM and PG.
See Also
For more information on working with approval workflows in Process Governance, please read the following excerpt of our user guide: https://documentation.signavio.com/suite/en-us/Content/process-manager/userguide/approval-workflows.htm?Highlight=approver
Keywords
process, governance, workflow, approval, approver, approve, assign, case, table, value, user, no, set , KBA , BPI-SIG-PG-EDT , Process Governance Editor , Problem