SAP Knowledge Base Article - Public

3278731 - Why am I unable to add a license or move a user from one User Group to another via API?

Symptom

I am unable to add a license or move a user from one User Group to another via API?

Environment

SAP Signavio Process Manager 3.0

Reproducing the Issue

  1. Open Postman (3rd Part Tool).
  2. Prepare a POST api call to update your Signavio users.
  3. Add the required parameters and headers.
  4. Upload the csv file with the updates.
  5. Send the POST.
  6. See a success message in Postman.
  7. Login to Signavio Process Collaboration Hub.
  8. Navigate to the User management settings.
  9. Select the user tab.
  10. Click on a user whose licenses should have changes with API update but see that they did not.

Cause

The api was not updating your existing users assigned licenses or groups as the csv file being used included incorrect capitalization. The groups and licenses tabs that included 'Collaboration hub' should have instead included 'Collaboration Hub' with a capital 'H' in Hub.

Resolution

For the changes to take effect, please include a capital 'H' in Hub when referring to the Collaboration Hub in either the licenses or groups tab.

See Also

For more information on updating user licenses and assigned groups, please read the following excerpt from our user guide: https://documentation.signavio.com/suite/en-us/Content/process-manager/security-guide/user-management.htm?#Changeusersettings

Keywords

process, manager, explorer, user, manage, update, license, api, group, assigned, assignment, post , KBA , BPI-SIG-CA-SEC-UM , User Management for SAP Signavio , Problem

Product

SAP Signavio Process Manager 3.0