Symptom
I am unable to add a license or move a user from one User Group to another via API?
Environment
SAP Signavio Process Manager 3.0
Reproducing the Issue
- Open Postman (3rd Part Tool).
- Prepare a POST api call to update your Signavio users.
- Add the required parameters and headers.
- Upload the csv file with the updates.
- Send the POST.
- See a success message in Postman.
- Login to Signavio Process Collaboration Hub.
- Navigate to the User management settings.
- Select the user tab.
- Click on a user whose licenses should have changes with API update but see that they did not.
Cause
The api was not updating your existing users assigned licenses or groups as the csv file being used included incorrect capitalization. The groups and licenses tabs that included 'Collaboration hub' should have instead included 'Collaboration Hub' with a capital 'H' in Hub.
Resolution
For the changes to take effect, please include a capital 'H' in Hub when referring to the Collaboration Hub in either the licenses or groups tab.
See Also
For more information on updating user licenses and assigned groups, please read the following excerpt from our user guide: https://documentation.signavio.com/suite/en-us/Content/process-manager/security-guide/user-management.htm?#Changeusersettings
Keywords
process, manager, explorer, user, manage, update, license, api, group, assigned, assignment, post , KBA , BPI-SIG-CA-SEC-UM , User Management for SAP Signavio , Problem