SAP Knowledge Base Article - Public

3279375 - Employee Data Not Visible/Updated After Basic Import

Symptom

  • After performing an employee data import, some records failed with exception: "Exception caught: com.successfactors.sca.service.exception.ServiceCreateFailedException: can not get personId" or Exception caught: DAOException caught:[key=EMPLOYEE_HRIS_GO_MULTIPLE_ICS_FOR_SAME_EC, values=[[XXXXXXX]]]
  • Basic import is processed successfully and no error is found in the import, however employees are not visible in the instance

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Go to 'Import Employee Data'
  2. Select 'Basic Import' and import your file.
  3. Go to Monitor Job, download the job file and view the error.
  4. Go to Monitor Job, download the job file and view the error "Exception caught: com.successfactors.sca.service.exception.ServiceCreateFailedException: can not get personId"
  5. In some cases no error is seen on the import, however employees are not imported either visible in the tenant.

Cause

This inconsistency may be caused due to the dirty data on orphan person GO which holds employee ID

Resolution

  1. Go to Admin Center > Navigate to Check Tool;
  2. Under Application, select "User Management" > Click Go;
  3. Find the following check: "Each employee's person data is correctly associated with corresponding employment data. (OrphanPersonGOs)" > Run the check;
  4. Click on the "Each employee’s person data is correctly associated with corresponding employment data." box.
  5. In the new box that opened, run the Quick fix, and proceed in the next 3 tabs.
  6. Import the file again, then verify if the user imports successfully.

Note: If you have already followed the recommended steps above, seen the results shown below in the check tool, and successfully completed an import, but still do not see the user in UDF and have received the following error message via email notification, please kindly reach out to LOD-SF-PLT-MNG for further assistance.

For Support Engineer, please review the internal memo of this KBA.

SAMPLE ERROR MESSAGE VIA EMAIL NOTIFICATION:

TROUBLESHOOTING:

Errors: 

  1. The following users were not imported or updated because the assignment UUIDs column can’t be updated: [XXXXX]

OR

Errors: 1. System error when loading users: XXXXX -retVal: 1Exception caught: com.successfactors.sca.service.exception.ServiceCreateDailedException: can not get personId or

“ServiceLegacyRollbackException: retVal:1 & Exception caught: com.successfactors.sca.service.exception.ServiceCreateFailedException: cannot get personId.

FAQ - Additional Information

Q) Where can I get information on this from the Guide?

 A) Guide:Using the Check Tool   and  Using the Quick Fix Feature                                                                                                                                                      

    

See Also

  1. 2786737 How to delete an orphaned Person ID with Compound Delete functionality
  2. 2598644 How to delete Orphaned Person ID
  3. 2797141- Imployee Import/Export Data
  4. 2613892 How to remove/Purge Orpahned ID's
  5. 2092826 BACKLOG - How to create unique Personal ID? - Employee Central
  6. 2438812 - Check Tool: How to use Check Tool to check if there are any Orphan Person ID Externals in the system. (OrphanPerson) 
  7. 2545988 How To Purge or Delete Users In SuccessFactors
  8. 3075524 - OData API error : "ServiceCreateFailedException: can not get personId"
  9. 2287959 - Person ID External already exists

Keywords

INC15273498, exception, ServiceCreateFailedException, personId, EMPLOYEE_HRIS_GO_MULTIPLE_ICS_FOR_SAME_EC, OrphanPersonGOs, check tool, Basic Import, user not visible, Each employee’s person data is correctly associated with corresponding employment data. (OrphanPersonGOs) , ServiceCreateFailedException: can not get personId, can not get personId, The following users were not imported or updated because the assignment UUIDs column can’t be updated , KBA , LOD-SF-PLT-MNG , Manage user Issues , LOD-SF-EC-EDP-BIO , Biographical Information Import , LOD-SF-EC-DRM , Data Retention Management - (DRM & DRTM) EC Data Only , Problem

Product

SAP SuccessFactors HCM Core all versions

Attachments

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