SAP Knowledge Base Article - Public

3279375 - Employee is not visible or updated after Basic Import is processed

Symptom

  • After performing an employee data import, some records failed with exception: "Exception caught: com.successfactors.sca.service.exception.ServiceCreateFailedException: can not get personId"
  • Basic import is processed successfully and no error is found in the import, however employees are not visible in the instance

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Go to 'Import Employee Data'
  2. Select 'Basic Import' and import your file.
  3. Go to Monitor Job, download the job file and view the error.
  4. Go to Monitor Job, download the job file and view the error "Exception caught: com.successfactors.sca.service.exception.ServiceCreateFailedException: can not get personId"
  5. In some cases no error is seen on the import, however employees are not imported either visible in the tenant

Cause

This inconsistency may be caused due to the dirty data on "orphan person GO which holds employee ID.

Resolution

  1. Go to Admin Center > Navigate to Check Tool;
  2. Under Application, select "User Management" > Click Go;
  3. Find the following check: "Each employee's person data is correctly associated with corresponding employment data. (OrphanPersonGOs)" > Run the check;
  4. Click on the "Each employee’s person data is correctly associated with corresponding employment data." box.
  5. In the new box that opened, run the Quick fix, and proceed in the next 3 tabs.
  6. Import the file again.

Keywords

exception, ServiceCreateFailedException, personId, EMPLOYEE_HRIS_GO_MULTIPLE_ICS_FOR_SAME_EC, OrphanPersonGOs, check tool, Basic Import, user not visible , KBA , LOD-SF-PLT-UIM , Employee Import Issues , Problem

Product

SAP SuccessFactors HCM Core all versions