Symptom
- The Average exception aggregation does not consider unbooked data in SAP Analytics Cloud (SAC).
- When using the Average exception aggregation in SAC, the result values are not as expected.
- This KBA will describe a workaround to consider unbooked data in average calculations in SAC.
Environment
- SAP Analytics Cloud (Enterprise)
Cause
- Working as designed / missing feature.
Resolution
Workaround:
- Create a new calculated measure/account called: numberOfPeriods
- Add a value of 1 into the formula of the new account called numberOfPeriods.
- Set exception aggregation to Count with the exception aggregation dimension with your Date dimension
- Use this new measure/account (numberOfPeriods) to create a new calculated measure/account called: customAverage
- Set the formula to [Volume]/[numberOfPeriods]”
- As you can see below, the Custom Average now returns as expected 3.33 (10/3), while the simple Average measure (using Average exception aggregation) returns 10 (10/1 as just one month is booked).
Limitation: Please note inputting data into this new average account is not supported since an inverse formula is not directly supported due to the exception aggregation.
See Also
- 3275758 - "Average"/"Count" exception aggregation not working as expected in SAC / MDS
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an incident for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped, sap analyst cloud, https://hcs.cloud.sap, https://hanacloudservices.cloud.sap, https://cloudanalytics.accounts.ondemand.com, https://hanacloudservices-us.accounts.ondemand.com, https://www.sap.com, https://help.sap.com, predictive analytics (analysis), data analysis (analytics) tools, analytics tools, sap analytics cloud, data literacy, advanced analytics, data democratization, analytics software, real time analytics, self service analytics, advanced data analytics, analytics as a service, analytics cloud / cloud analytics, saas analytics, cloud bi, enterprise planning, cloud data analytics, cloud based analytics, analytics cloud platform, modern analytics, real time analysis, cloud analytics solution(s), what is sap analytics cloud, cloud analytics tools, analytics in the cloud, cloud analytics software epm, business intelligence, , KBA , LOD-ANA-DES , Story Design & Visualizations , LOD-ANA-PL , Planning , LOD-ANA-ML , SAC Modelling , Problem
SAP Knowledge Base Article - Public