Symptom
Service Order Delivery Status is not changed from Finished to Not Started or In Process even though the Service Confirmation was cancelled via a Reason for Rejection.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Order work center
- Search for the Service Order ABC (ABC is service order ID)
- Navigate to Services and Spare Parts tab
- Click on the Add Row button and enter Product ABC (where ABC is product ID of type Service - time and material) and Save the Service Order.
- The Service Order PQR (where PQR is service order ID) is created.
- Click on the action Submit-> Release to Service Execution.
- Go to the Field Service and Repairs work center.
- Go to the Order Pipeline view and select ALL Orders to be Executed from drop-down option and search with service order ID PQR.
- Select Service Order PQR and click on Confirm Execution button.
- In the New Service Confirmation screen ,click on the button Save and then Release the Service Confirmation LMN(where LMN is Service Confirmation ID).
- Edit Service Confirmation LMN and go to Services and Spare Parts tab and maintain the Reason for Rejection for item ABC and Save it.
- Now go to Service Order PQR and under the Services and Spare Parts tab for item ABC the Delivery Status should have revoke to In Process, but it is still showing as Finished.
Cause
When you remove the Reason for Rejection in the Service Confirmation the warning message is displayed that fulfilment of order item was not revoked, because the item is invoiced.
Since the Invoice was created the Invoice Status is Finished and therefore the Delivery Status does not change when the Service Confirmation is canceled.
Resolution
You need to cancel the Customer Invoice to update the Invoice Status which then will also update the Delivery Status in the Service Order.
Keywords
Service Order, Service Confirmation, Revoke, Reopen, reason for rejection , KBA , SRD-CRM-SEO , Service Orders , Problem
SAP Knowledge Base Article - Public