SAP Knowledge Base Article - Public

3279797 - Missing Report Access Context Despite User Restrictions.

Symptom

When users view a certain report, the access context in that report is Unrestricted. However, you have maintained restrictions on user level / business role level for all relevant work centers so you would expect the report to be restricted.

Environment

  • SAP Business ByDesign
  • SAP Cloud for Customer

Cause

There are 2 possible causes:

  1. The work center view that the report is assigned to has a conflict. You can check this as follows:
    1. Go to the work center Business Analytics and the view Design Reports.
    2. Search for your report.
    3. Click Assign.
    4. Show all assigned work center views.
    5. It is assigned to views with a conflict - see the "Conflict" column.
  2. The report itself does not have an access context. This means that it's always unrestricted. You can check this as follows
    1. Go to the work center Business Analytics and the view Design Reports.
    2. Search for your report.
    3. Mark the report and in the table underneath the report list, check the "Access Context" entry. If it is empty, the report is not restricted. 

Resolution

Depending on the cause:

  1. When assigned to a conflicting work center view, the report is always unrestricted. Please change the assignment to another view without conflict.
  2. Such reports cannot be restricted by user access rights. You could consider creating a copy of the report. In step 4, you can maintain fixed value selections. Here, you could set a relative restriction such as "My User Name", depending on how you would like the report to be restricted.

See Also

KBA 2488825 - Access Context of Report Not Working

KBA 2575041 - Conflict of access context during report assignment

Keywords

reporting, access context, missing restriction, too much data, business analytics, user restrictions , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer core applications all versions