SAP Knowledge Base Article - Public

3279800 - Android user cannot update profile picture in SuccessFactors Work Zone

Symptom

In SAP Work Zone Mobile, when using Android operational system, user cannot update profile picture because the upload image button is not active.

Environment

SAP SuccessFactors Work Zone

Reproducing the Issue

  1. Go to User Profile
  2. Scroll down
  3. Click on 'Upload an Image'
    Nothing happens

Cause

Android WebView is used to load the page.

Resolution

The workaround is to open in browser to modify the profile picture. 

Android's WebView does not allow uploading and downloading files. You can use “open in browser” to perform these actions. Note that even if these buttons are visible in WebView, they are not supported.

Note that if you do not agree with this system behavior, the official and supported way to request this feature to be reconsidered, is by creating an enhancement request. All enhancement requests are reviewed by our Product Management team and, if successful, are developed and implemented in a future product release.

See Also

Help Portal guide Restrictions | SAP Help Portal

2090228 - How to Submit Enhancement Requests for SAP SuccessFactors Products

Keywords

workzone mobile, work zone mobile, work zone android, work zone profile picture, android profile, upload profile picture, upload profile image, work zone picture, workzone profile , KBA , LOD-SF-JAM-SWZ , Collaboration Features , Problem

Product

SAP SuccessFactors HXM Suite Core 2205