Symptom
You are configuring the UK MTD for VAT Return submission in the Test system and you see the error message - Client Registration missing; contact administrator.
Environment
SAP Business ByDesign
Reproducing the Issue
- Login to Test system Only.
- Go to the Business Configuration work center.
- Click on Overview.
- Search and open the UK Making Tax Digital activity.
- Enter the VAT Registration Number.
- Click on Allow Access.
- You get the error message - Client registration missing; contact administrator.
Cause
The HMRC does not provide any sandbox/test system. Hence we suggest you not to configure UK MTD in the Test System as any successful submission carried out in the Test System will result in a live Tax Submission to HMRC.
Resolution
You can configure the UK Making Tax Digital (MTD) for VAT, directly in the Production system.
Keywords
Client registration missing; contact administrator, UK MTD , KBA , client registration missing; contact adm , uk mtd , SRD-FIN-GLO-TAX , GLO - Tax Declaration , Known Error