SAP Knowledge Base Article - Public

3280104 - Account Disappears After Adding a Party Role in Responsibilities Tab

Symptom

You noticed that after adding a Party Role to an Account, the account disappears from Accounts Work Center.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Account Management Work Center.
  2. Go to Accounts View.
  3. Select the Account and click Edit button.
  4. Go to Contacts tab and go to Responsibilities subtab.
  5. Click Add Row.
  6. Add a Party Role and select an Employee.
  7. Click Save.
  8. Search for the account again in Accounts Work Center.

The account disappeared

Cause

This system behavior might be occurring because access restrictions for the user and the access to accounts are maintained.

In order to check it, please follow the steps below:

  1. Go to Application and User Management Work Center.
  2. Go to Business User View.
  3. Search for the Employee that no longer sees the Account and select it.
  4. Click Edit button -> Access Rights.
  5. Go to Access Restrictions tab.
  6. Search for Work Center ID BPM_ACCOUNTS.
  7. Check if the Read and Write access is selected as Restricted.
  8. Go to Detailed Restrictions subtab.
  9. Check the Employee that are selected.

According to this, the user may only see accounts for which the employees are listed as employee responsible (or no employee responsible is listed at all).

Resolution

This is an expected system behavior.

See Also

Please also refer to the explanations in the documentation about access restrictions for accounts:

Help Center - Access Rights and Restrictions for Accounts

Keywords

party role; account; access rights; BPM_ACCOUNTS , KBA , SRD-MD-BP , Business Partner , How To

Product

SAP Business ByDesign all versions