Symptom
The following error occurs when the Hiring Manager or I-9 Responsible User attempts to access the "Complete Form I-9 Section 2" task from the Onboarding Dashboard → Error: [COE0019] Process not found for Id: <ComplianceProcessId>
Note: The same task can be accessed successfully from the Home Page, without any error.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Proxy as the Hiring Manager or I-9 Responsible User.
- Navigate to the Onboarding Dashboard.
- Search for the affected onboardee.
- Under Form I-9 and E-Verify > Task: Complete Form I-9 Section 2
- Start
- Error: Error: [COE0019] Process not found for Id: <ComplianceProcessId>
Cause
- The "Compliance Process" permission, along with other compliance-related permissions, is missing from the Hiring Manager or I-9 Responsible User's permission role.
- The current Target Population for the role is set to "All (External Onboarding User)" - which is no longer applicable once the candidates are hired.
Resolution
- Grant the "Compliance Process" permission along with all other relevant compliance-related permissions within the respective permission role.
- If the affected candidates have already been hired, update or add the Target Population to "All Employees".
Keywords
onboarding, dashboard, i-9, section, 2, COE0019, process, not, found, for, id , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public