SAP Knowledge Base Article - Public

3280403 - Supplier Multi-Channel settings cannot be updated using Migration or Mass Data Maintenance

Symptom

You are trying to update multi-channel collaboration data for a supplier using Migration tool Mass Data Maintenance but it ends in error.

Environment

SAP Business ByDesign

Cause

When using Multi-Channel settings, neither the migration with mode “Enhance Already Existing Records” nor the mass data maintenance allows updating these settings.

Refer KBA 2825855 for further details

Resolution

You can always update it in the UI. If the number of Suppliers to be updated is large and if the process it time consuming then the only possibility would be via Web Service.

Please refer the sample payload below

<n0:SupplierBundleMaintainRequest_sync_V1 xmlns:n0=" http://sap.com/xi/SAPGlobal20/Global ">
<BasicMessageHeader>
</BasicMessageHeader>
<Supplier actionCode="02" >
<InternalID>XXXXXX</InternalID>
<CommunicationArrangementMultiChannel actionCode="04" communicationChannelListCompleteTransmissionIndicator="true">
<CompoundServiceInterfaceCode>11</CompoundServiceInterfaceCode>
<EnabledIndicator>true</EnabledIndicator>
<CommunicationChannel communicationEmailListCompleteTransmissionIndicator="true">
<CommunicationMediumTypeCode>INT</CommunicationMediumTypeCode>
<CommunicationEmail>
<EmailURI>xx@xx.xx</EmailURI>
<RecipientFieldTypeCode>TO</RecipientFieldTypeCode>
</CommunicationEmail>
</CommunicationChannel>
</CommunicationArrangementMultiChannel>
</Supplier>
</n0:SupplierBundleMaintainRequest_sync_V1>

 

Keywords

multi-channel collaboration, supplier , KBA , AP-BP-SUP , BusinessByDesign: Supplier , Problem

Product

SAP Business ByDesign 2208