Symptom
- The notification count displayed in the header bell icon changes between different numbers after login or when proxying as another user.
- The number fluctuates for a short period while the page is loading.
- After a few seconds, the notification count stabilizes and displays the correct number.
- This behavior is observed when accessing the To-Do panel.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Login or Proxy as any user who has some notifications in the To Do panel.
- Check the notification bell icon
- It will alternate between few numbers when the page loads, before finally settling in on the correct number of notifications.
Cause
The header has multiple layers of caches to save data and processing to only when needed. There is a cache on the browser level and also on server level when page loads.
When a user logs in to get new session or clicks on the Bell icon to load the To-Do panel, it hits the server directly to collect the most current data. While the new session loads, the cached data is collected and displayed first, hence causing the alteration between the different numbers before finally settling on the correct number.
Resolution
This is expected system behavior.
No action is required.
To‑Do Panel Hidden When Latest Shell Bar Experience Is Enabled
If the latest experience for the SAP shell bar is enabled, the To‑Do panel/icon will not appear in the header as documented in Changes Included in the SAP User Experience Updates | SAP Help Portal
This is because the To‑Do panel is being deprecated as it no longer aligns with SAP’s latest user experience standards.
See Deprecation of To-Do Panel | SAP Help Portal for more details on the deprecation.
How to Check Whether the Latest Shell Bar Experience Is Enabled
- Go to Company System and Logo Settings.
- Search for Enable the latest SAP shell bar.
- If this is checked, the To-Do Panel will NOT be displayed on the header / shell bar.
- If this is unchecked, the To-Do Panel will be displayed.
See Also
- SAP Help Portal - Changes Included in the SAP User Experience Updates
- SAP Help Portal - Deprecation of To-Do Panel
Keywords
notification count, bell icon, header, To-Do panel, changing count, caching, delay, login, proxy, SuccessFactors , KBA , LOD-SF-PLT-TOD , To-Do List Issues , Problem
SAP Knowledge Base Article - Public