Symptom
Sales Order and Sales Order Item fields are not editable once Tickets are created.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Open the Ticket 123 (Where 123 refers to the Ticket ID).
- Go to the Overview tab.
- Click Edit.
- Edit Sales Order and Sales Order Item in Additional Information.
Result: Unable to edit these fields.
Cause
Sales Order and Sales Order Items fields in Ticket are available to manually associate Sales Orders to tickets.
In cases, where Tickets are created out of Sales Orders, these fields can be used to link them. However, these fields cannot be changed after Tickets were created and this is expected system behavior.
- Please note: "Sales Order Item" will not automatically populate on Ticket creation, but can be used to manually link a Sales Order Item.
Resolution
This is expected system behavior.
If this feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
Keywords
Sales Order, Sales Order Item, cannot edit, not editable , KBA , LOD-CRM-SRP , Service Request Processing , Problem
SAP Knowledge Base Article - Public