SAP Knowledge Base Article - Public

3281375 - FSM Tickets Are Doubling Materials

Symptom

Double posting of materials in FSM, Quantities are being deleted and re-entered in tickets leading to FSM tickets having twice as many items present.

Environment

SAP Cloud for Customer

SAP FSM

Reproducing the Issue

  1. Navigate to Service work center.
  2. Navigate to Tickets work center view.
  3. Search for relevant Ticket ID and open it.
  4. Navigate to Changes tab.
  5. Observe double entries.

Cause

Wrong action code on the outbound payload from C4C.

Action code 02 meaning it would try and Update meaning; the system returns an error message if the node element does not exist.

Resolution

Change to action code 04 Save; the system creates or changes the node element data.

Or change to relevant action code required for the  particular scenario.

01 Create; the system returns an error message if the node element already exists.

02 Update; the system returns an error message if the node element does not exist.

03 Delete; the system returns an error message if the node element does not exist.

04 Save; the system creates or changes the node element data.

05 Remove; the system deletes the node element. If the node element does not exist, the system does not send an error message.

06 No Action; the system does not change the node element.

Keywords

Action codes, FSM integration, Service tickets, C4C, Payload, Double, Entries, Multiply, Multiplied , KBA , LOD-CRM-INT-CRM , Integration of C4C with CRM , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions