SAP Knowledge Base Article - Public

3281517 - Custom country specific field is cleared out during import - Employee Central

Symptom

While making a Job History import, a custom Country/Region-Specific picklist field is cleared out in the imported record, even not being part of the import template. The same behavior happens if the expression "&&NO_OVERWRITE" is added in the field in the import file.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to 'Import Employee Data' and select the option to import Job History
  2. Select a file that does not include the custom country-specific field, or that includes it with the expression "&&NO_OVERWRITE&&"
  3. Proceed with the import
  4. Check the Job Information of the affected user: the custom field is cleared out

Cause

The same custom field is configured in a different country with different settings or with a different picklist assigned.

Resolution

When a custom field is configured for multiple countries, it needs to have the same configuration in all of them.

For example: if the field custom-string50 is configured as a picklist in country USA and it is associated to picklist "yesNo", this same custom-string50 needs to be a picklist field associated to "yesNo" in all other countries. Otherwise, this field will be cleared out during import.

To maintain different settings for custom fields, please use different custom IDs. 

See Also

Keywords

import, country specific field, picklist, cleared out, &&NO_OVERWRITE&&, job history, incremental load, CSF , KBA , LOD-SF-EC-EDP-JOB , Job Information Imports , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions