Symptom
The Delivery Status of an Item in a Service Order is still Finished even though the Service Confirmation was cancelled.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Orders work center.
- Select the Service Order Processing view.
- Search for the Service Order ABC (ABC is service order ID).
- Navigate to Services and Spare Parts tab.
- Select the Line Item XX for Service ABC (where ABC is product ID of type Service - time and material and XX is the line item number).
- The Delivery Status is Finished.
- Go to the Document Flow tab and open the Service Confirmation that was created for Service ABC.
- Navigate to Services and Spare Parts tab.
- Select the line Item in which you confirmed the Service ABC.
- You can see that the item was cancelled via a Reason for Rejection.
- You expect that since the Service Confirmation was cancelled that the Delivery Status of the item should have been revoked to In Process, but it is still showing as Finished.
Cause
The Service Confirmation was already Invoiced.
When you entered the Reason for Rejection in the Service Confirmation, there is was a warning message displayed: Fulfillment of item XX in order ABC was not revoked, item already invoiced.
Resolution
You need to cancel the Invoice to revoke the status in the Service Order.
Keywords
Service Order, Service Confirmation, Revoke, Reopen, reason for rejection , KBA , service order , service confirmation , revoke , reopen , reason for rejection , AP-SVO-SO , Service Order , How To
SAP Knowledge Base Article - Public