Symptom
- You are using an SMS integration in SAP Cloud for Service per the "SMS service Configuration for Campaign" blog
- You have also defined a workflow to send SMS per the "Setting up outbound SMS service in SAP C4C using third-party APIs"
- However, once the workflow is triggered, the SMS fails with the message "The gateway returned an error while sending the message. HTTP Code 406"
Environment
- SAP Cloud for Customer
- SAP Cloud for Service
- SAP Cloud for Sales
Cause
- Configuration
- 3rd party issue
Resolution
- Ensure that the target URL is correct and does not have any spaces. We suggest not to copy paste the URL but rather entering it manually
- Go to Administrator -> Mashup web services
- Fill all the mandatory information, and specially the URL – The SMS service provider’s URL (enter this manually)
- Ensure that the SMS provider information is valid and correct (for example, API Key, URL, Shortcode, and Method used like POST vs Get)
See Also
- 2601436 - Requirements for SMS Web Services Problems
- 3032862 - SMS Workflow Fails With Reason: Maintain The Mandatory Contact Number For Recipients
- 2363435 - Outbound SMS Is Not Sent Via Workflow Rule
- 2869123 - SMS Getting Truncated when Sent via Workflow Rule
- 2440710 - SMS Notifications Through Workflow Rules Have UTC Time Stamp
- 3023674 - SMS Sent Via Workflow Rule Does Not Show Up In Ticket Interactions
- Send SMSes In Multiple Languages Using User Preferences
Keywords
SMS, Workflow, URL, Error, Messaging, PROCESS_OUTBOUND_MESSAGING, CL_COD_SEOD_OUT_MESSAGING_UTIL , KBA , LOD-CRM-SC-MES , Messaging / SMS , LOD-CRM-WKF , Workflow , Problem
Product
SAP Cloud for Customer core applications 2211