Symptom
The users on groupware settings are showing the following error message.
"The Remote Server Returned An Error: (502) Bad Gateway."
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to E-mail Integration Work Center.
2. Open the Groupware settings.
3. Check the affected user.
4. The following error is appearing: "The Remote Server Returned An Error: (502) Bad Gateway."
Cause
The user has more than 50.000 records available under filter e.g: My Records (or any other filter that is currently set in Customization).
When we run synchronization, we query all entities that are covered by this filter.
Resolution
You can check under OData API Monitor and search by the user which is facing the issue.
There should appear the following error on payload:
{"error":{"code":"","message":{"lang":"de","value":"Your search returned more than 50,000 results. Refine your filter and try again."}}}
The solution is to change the filter to any different one that meets C4C limit of 50.000 objects.
The filter itself should be changed in the following path:
1. Groupware Settings.
2. Users tab.
3. Open the affected user.
4. On right side of Profile option, click Customize.
5. Under Sync Settings search for the Object Card.
6. Change the filter to another filter that meets C4C limit of 50.000 objects.
Please note, the limit of 3000 is Server Side Integration configuration where it correspondingly scopes a number of objects that are needed to be synchronized.
A limit of 50.000 records is coming from C4C.
Keywords
Groupware, Error, Gateway, Bad, Server, Returned, User , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To