SAP Knowledge Base Article - Public

3282963 - C4C Inbound Service Interface Failing With “Time Limit Exceeded.”

Symptom

You are replicating data from External System to Cloud for Customer, however the inbound message is failing with the following error: "Time limit exceeded.".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Click on General Settings work center view.
  3. Open the Web Service Message Monitoring under System Administration.
  4. Search for the Service Interface or the message ID.
  5. You will be able to see the error: "Time limit exceeded.".

Cause

The messages will temporarily show this error if there is any interdependence between the objects available in multiple messages. To ensure that such messages will not fail but will be automatically reprocessed, the system will retry 7 times. Sometimes, if a user is in the business object in edit mode for a long time without doing anything, this error can occur. The retry mechanism is used to reprocess the message in one of the seven attempts.

Another possibility is that you're sending the same business object in a different payload while the original is still being process.

Resolution

To fix the issue, you need to manually resend the message. You also need to ensure that the lock will be removed from the business object and that there is no message for it in Waiting Status.

Keywords

Time Limit Exceeded, Time, Limit, Exceeded, C4C, Cloud for Customer, Inbound Message, Inbound, Web service message monitoring, Web service message, Web service, Incoming. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To

Product

SAP Cloud for Customer core applications 2211