SAP Knowledge Base Article - Public

3283003 - C4C Inbound Service Interface “MaterialReplicationInitiatedByExternalIn” Error: Solve Configuration Issue in ID Mapping for Element SALES_PRICING_MATERIAL-ID-CONTENT With ID XXXXXXXXXXXX

Symptom

You are replicating Material from External System to Cloud for Customer, however the inbound Service Interface "MaterialReplicationInitiatedByExternalIn" message is failing with the following error: "Solve Configuration Issue in ID Mapping for Element SALES_PRICING_MATERIAL-ID-CONTENT with ID XXXXXXXXXXXXXX"

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisites: you have a working integration scenario between C4C and ERP/ S4H for interface MaterialReplicationInitiatedByExternalIn.

  1. Go to the Administrator Work Center.
  2. Click on General Settings.
  3. Open the Web Service Message Monitoring View.
  4. Search for the Message ID from the Service Interface "MaterialReplicationInitiatedByExternalIn".
  5. You will be able to see the error.

Cause

The issue is that fields:

<SenderSequenceNumberValue>20240101010101</SenderSequenceNumberValue>
<ID>00000000000123456</ID> (where 00000000000123456 means Material ID)

And

<SalesPricingMaterial>
<ID>00000000000123456</ID>

have the same value.

Resolution

This is expected behavior and this would be consider as a new requirement in C4C. To resolve please correct the data in ERP to solve the error.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

MaterialReplicationInitiatedByExternalIn; SALES_PRICING_MATERIAL-ID-CONTENT; WSM; Communication System , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To

Product

SAP Cloud for Customer core applications 2211