Symptom
You would receive an application error when trying to save data for Personal Information from People Profile.
The application error id would be accompanied by error message:
- Please try again later or notify support if this issue keeps occurring."
- You do not have permission to edit the value. Please contact your system administrator
- internal log: errorMessages=[Security mismatch error is caused by: No record hash field in UI request/rowData.Please check UI request for elementId:globalInfo]
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to People Profile
- Try to edit Personal Information
- Upon saving, error pops up as:" An application error occurred. Please try again later or notify support if this issue keeps occurring."
Cause
globalInfo hris element or globalInfo for user's specific country is not enabled in Manage Business Configuration.
Another Example Splunk log error
- errorMessages=[Security mismatch error is caused by: No record hash field in UI request/rowData.Please check UI request for elementId:globalInfo]
Resolution
Please enable globalInfo or globalInfo for user's specific country from Manage Business Configuration.
Via UI
- Go to Manage Business Configuration
- globalInfo
- click on Configure New Country/Region
- select missing globalInfo country from Country/Region
- add some field base on county ( globalInfo is required to be enabled view Country/Region-Specifics for Employee Central /
Example : Example list of globalInfo field for country Netherlands Chapter Global Information - Netherlands
Via Data model
- Export EC Country/Region Master Data model? Via 3153500 - How to Download Data Models, Picklists and other configuration files for Employee Central - SuccessFactors
- Import : missing globalInfo country via3066117 - How to export Data Models?
Important
- Though the hris-element is required - it does not need to be filled in during the Hire wizard.
- Make sure that the "globalInfo" hris-element is configured in the Succession Data Model - this is required for Ad Hoc reporting to work correctly.
- If you do not wish to use globalInfo, then you do not need to configure any Country Specific globalInfo fields in the Country Specific Succession Data Model or BCUI - this will mean that the "Global Information" section in Personal Information portlet will be unavailable in the UI.
- This table is a "child" hris-element, linked to the personalInfo hris-element.
FAQ - Additional Information
Q) Where can I get information on this from the Guide?
A) Guide: Country/Region Specifics in Employee Central | SAP Help Portal
- Chapter Country/Region-Specifics for Employee Central
- Chapter:Global Information (hris-element-id: globalInfo)
Q) Where can I get EC Master Data model?
A) View 3153500 - How to Download Data Models, Picklists and other configuration files for Employee Central - SuccessFactors
See Also
- Country/Region Specifics in Employee Central | SAP Help Portal
-
3547262 - Missing globalInfo country Under Personal Information Does Not Allow personal
-
2352973 - Cannot Run an Adhoc Report on Custom field with Employment Info (as of Date) for Specific Country " CSF Data Model"
-
2533354 - Missing field in global info portlet
-
2236017 - Mass Deletion of MDF Data via Import
-
3066117 - How to export Data Models?
- 2586311 - Manage Business Configuration: Which hris-elements must be enabled and configured for Employee Central
- 3153500 - How to Download Data Models, Picklists and other configuration files for Employee Central - SuccessFactors
Keywords
An application error occurred. Please try again later or notify support if this issue keeps occurring, globalInfo, Manage Business Configuration, errorMessages=[Security mismatch error is caused by: No record hash field in UI request/rowData.Please check UI request for elementId:globalInfo] , Please try again later or notify support if this issue keeps occurring ,You do not have permission to edit the value. Please contact your system administrator , KBA , LOD-SF-EC-PER-GLO , Global Info - Config, Rules, RBP, UI , How To
SAP Knowledge Base Article - Public