Symptom
While Migrating Customer, system throws an error message :
"You have already created a relationship with the same business partner. Adapt the relationship you just added or remove it."
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Business Configuration work center.
- Select Overview view.
- Search and open Migration of Customers activity.
- Select Migrate Contacts using the Migration Tool.
- Upload the Migration Template using the Upload option.
- Select Execute Migration.
Cause
You are trying to add a new contact ID to an existing business partner ID and you may have entered the same relationship twice: once in the tab "Relationship" and also in the tab "Contact Details".
Resolution
If you have a contact person and need to add the contact relationship to an account, you should only maintain this data in the tab "Contact Details".
The tab "Relationship" is meant to enter additional relationships for the contact, however not contact relationships.
See Also
https://launchpad.support.sap.com/#/notes/2633570
Keywords
Migration of Customer, contactID, business partnerID, contact relationships, additional relationships for the contact , KBA , migration of customer , contact details , contact relationships , additional relationships for contact , SRD-CC-MIG-CNT , Migration: Content , AP-BP-MIG , ByDesign: Business Partner Migration / Replication , Problem