Symptom
e-Verify not triggering if the candidate is restarted.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Candidate go through standard Onboarding Process
- e-Verify is triggered and finished
- Candidate is restarted in Onboarding
- e-Verify is not triggered
Cause
When the onboarding process is restarted it cancels the existing process and create new one. But SAP Support cannot cancel/restart e-verify, because it's 3rd party integration and the case can only be closed manually by a user. So, it is the best to keep e-Verify case open on Onboarding process restart. This e-verify process is still connected to original Onboarding process.
There is a limitation in Onboarding dashboard. It cannot show the details of cancelled processes. Given that e-verify is connected to original Onboarding process, which was cancelled, it doesn't show it in UI.
If e-Verify process is still open, the To-DO should still be available and the user should be able to finish e-verify. If one needs the details of such case, it should be possible to create a report.
Resolution
Engineering team is aware of the issue and there is internal enhancement planned for b2305 release.
Keywords
KBA , LOD-SF-OBX , Onboarding 2.0 , Problem