SAP Knowledge Base Article - Preview

3283995 - "SmartEdit functionality may be compromised" error after Upgrading to SAP Commerce 2105+

Symptom

After upgrading to Cloud Commerce 2105.x version, SmartEdit starts to throw many error messages which are displayed in the screen and in the browser's console:

  • https://localhost:9002/personalizationsmartedit/personalizationsmartedit/js/personalizationsmarteditcontainer.js; SmartEdit functionality may be compromised.
  • Failed to load application 'cmssmarteditContainer' from location https://localhost:9002/cmssmartedit/cmssmartedit/js/cmssmarteditContainer.js; SmartEdit functionality may be compromised.
  • Http failure response for https://backoffice.xxxxxxxxx-xxxxxxxx-xx-public.model-t.cc.commerce.ondemand.com/personalizationsearchsmartedit/personalizationsearchsmartedit/js/personalizationsearchsmartedit.js: 404 OK


Read more...

Environment

  • SAP Commerce
  • SAP Commerce Cloud

Product

SAP Commerce 2105 ; SAP Commerce 2205 ; SAP Commerce Cloud 2105 ; SAP Commerce Cloud 2205 ; SAP Commerce Cloud 2211

Keywords

SmartEdit, failure response, 404 OK, Http failure response, Failed to load application, SmartEdit functionality may be compromised , KBA , CEC-COM-ADM-SEDIT , SmartEdit , Known Error

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.