Symptom
Users get an application error with fingerprint=a8dc3f346906a07f9f7b257156177701ef52c706 when accessing Benefits from their profile.
Environment
- SAP SuccessFactors Employee Central
- Global Benefits
Reproducing the Issue
- Log in as user
- Navigate to Employee profile
- Navigate to Benefits section of the employee profile
- Error is triggered
Cause
Configuration/data issue.
Resolution
Please follow the below steps to resolve the issue:
- Login to customer instance and navigate to Manage Data
- Search for Savings Plan benefits
- Open the Benefit configuration and if there are no entries available under Savings Account Benefit Details, Savings Plan USA, Savings Plan Deduction Details and Savings Plan Tier Configuration, please refer to the SAP Help documentation for appropriate field mappings. Add the data in the new objects and save the benefit. Values can be copied over from the older fields which have been marked read only in the release 2H 2022.
Keywords
BEN-11671, INC3483080, Savings plan, a8dc3f346906a07f9f7b257156177701ef52c706, b2211, INC3411224, SFExceptionConverterUtils, NullPointerException, benefits.savingsaccounts.SavingsAccountUSA.getSavingsPlanSubType(), BenefitHelper.getCountrySpecificSavingsAccountDetails(com.successfactors.benefitsmanagement.bean.benefits.savingsaccounts.SavingsAccountBenefitDetails)" is null , KBA , LOD-SF-EC-GBF , Global Benefits , Problem