SAP Knowledge Base Article - Public

3284233 - Rehire Co-ordinator Business Rule Error - Onboarding

Symptom

  • Rule execution for responsibility group assignment enters business process with error
  • The responsible group could not be fetched due to an API invocation failure. The failure occurred due to the following: Internal error.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Rule exists with Assign Responsible Group for Onboarding Rehire Check scenario
  2. Rule is added to ONB2Config in manage date
  3. Initiate onboarding from RCM for rehire
  4. Flow enters business process with error
  5. The responsible group could not be fetched due to an API invocation failure. The failure occurred due to the following: Internal error.

Cause

  • The issue is caused because of payComponentRecurring.frequency mapping. It is mapped to a frequency object which is not supported. Hence, rehire group assignment is failing. 
  • Ensure globalInfo.country is not mapped as can also cause issue.
  • Business Rule is not correctly configured, thus causing Rehire to fail.

Resolution

Solution 1: Change the frequency mapping to a String field and perform restart from Business Process Tile. Or: Remove the frequency mapping, maintain the frequency value at Pay Component Recurring FO to default the same

Solution 2: Remove mapping for global info country.

Solution 3: Check in Manage Data > Onboarding Configuration > whether "Rule for Rehire Coordinator Group Configuration" is configured with business rule and this rule is satisfied.
More information: Configuring a Business Rule to Assign Responsible Group for Rehire Check

Important to note: Support does not cover configuration matters, please engage the Implementation Partner in order to get the best assistance regarding business rules parameters, according to the needs of your business requirement. Alternately, speak with your Account Executive or Customer Engagement Executive about Professional Services options, or about engaging an SAP Authorized Partner. 2706322 - What is Support – What is Consulting: Cloud Solutions - SAP for Me  

Once each point is updated, perform restart from Business Process Tile once more.

See Also

Keywords

responsible, group, could, fetched, API, invocation, failure occurred due to the following, Internal, error, rehire, coordinator, Assign, Onboarding, Check, Rule, execution, responsibility, assignment, enters, business, process, frequency object, global info , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem

Product

SAP SuccessFactors Onboarding all versions