Symptom
The External ID field is not visible/available to add in Adaption Mode to the Ticket OWL
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service Workcenter
- Go to Tickets View
- Start Adaptation Mode
- The 'External Id' field is not available to be added in Ticket OWL screen.
Cause
This is the current behavior of the system. Integrated master data usually have the Object ID mapping linked which gets stored in External ID field of respective BO (Business Object). For transaction objects like Tickets, it is handled via BTD Reference, either as a predecessor or a successor. And this predecessor /successor object is linked to the C4C Ticket BTD Reference. As of now, we do not have a separate field for this scenario. We store this in BTD Reference Node ID.
Resolution
If this field is required in Ticket OWL, then a custom field can be used for this purpose and to fill the same, you can read BTD Reference Node ID and copy the external ticket ID into this and show the field in Ticket OWL.
Keywords
Ticket OWL, External ID, Adaptation , KBA , LOD-CRM-SRP , Service Request Processing , How To